Maintenance window.
Incident Report for Zinc
Resolved
Maintenance has been completed and successful.
Posted Sep 26, 2014 - 01:16 UTC
Identified
Messages will be slower to send from 6:10pm to 6:15pm PST.
Posted Sep 26, 2014 - 01:09 UTC