Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 11, 2026 - 09:00 UTC
Update
Please be advised that ServiceMax will be performing scheduled Data Guide Maintenance to apply a fix addressing a customer reported issue in FieldFX application on 11th April, 2026 between 5 PM to 6 PM UTC.
Posted Apr 09, 2026 - 15:47 UTC
Update
Please be advised that ServiceMax will be performing scheduled Data Guide Maintenance to apply a fix addressing a customer reported issue in FieldFX application on 11th April, 2026 between to 9 AM to 10 AM UTC.
Posted Apr 07, 2026 - 14:43 UTC
Update
Please be advised that ServiceMax will be performing scheduled Data Guide Maintenance to apply a fix addressing a customer reported issue in FieldFX application on 11th April, 2026 between to 9 AM to 10 AM UTC.
Posted Apr 07, 2026 - 14:35 UTC
Update
Please be advised that ServiceMax will be performing scheduled Data Guide Maintenance (This will involve applying latest patch to fix customer reported issues and any required security updates) on 11th April, 2026 between to 9 AM to 10 AM UTC. During this time, ServiceMax DG users may experience sporadic downtime.
This update targets to address an issue linked to population of Default Values on DataGuide Forms on the Web Interface for FieldFX app.
Posted Apr 07, 2026 - 14:26 UTC
Scheduled
Please be advised that ServiceMax will be performing scheduled Data Guide Maintenance (This will involve applying latest patch to fix customer reported issues and any required security updates) on 11th April, 2026 between to 9 AM to 10 AM UTC. During this time, ServiceMax DG users may experience sporadic downtime.
This update targets to address an issue linked to population of Default Values on DataGuide Forms on the Web Interface for FieldFX app.
Posted Apr 07, 2026 - 05:22 UTC
This scheduled maintenance affected: DataGuide (DataGuide Services).