Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 24, 2025 - 01:00 UTC
Scheduled
Please be advised that ServiceMax will be deploying a hotfix to address a critical issue identified in the A360 package following the recent Salesforce Summer ’25 platform release. This fix will be push-upgraded to all Sandbox and Production environments to ensure continued functionality and prevent disruption.
Issue Summary: * Package Affected: A360 * Issue: Component error occurs immediately upon opening the Asset360 Admin Setup. * Root Cause: A change introduced in the Salesforce Summer ’25 release has caused an unexpected conflict with A360 components. * Resolution: A hotfix will be deployed to restore full functionality and eliminate the error. Deployment Schedule: * Production Orgs: Saturday, May 24, 2025, between 1:00 AM – 2:30 AM UTC Impact: * Push-Upgrade may take 60-90 minutes, during this time ServiceMax A360 users on these orgs may experience sporadic downtime.. As per Salesforce general guidelines, we recommend that customers do not carry out any other deployments during this time.
Posted May 15, 2025 - 13:44 UTC
This scheduled maintenance affected: Critical Announcements, System Maintenance and Asset360 (Package Upgrade).